#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\/\/[a-z]+\.(?:[a-z]+\:?[0-9]+?|[a-z0-9]+\.[a-z]+)\/\bassets\b\/\bread\b\/((\w)+\.png)"
Local $sString = "//api.localhost:8000/assets/read/1453746564131_56a669843a3c1dac74170930.png" & @CRLF & _
"//api.olguat2.ca/assets/read/1453746564131_56a669843a3c1dac74170938.png" & @CRLF & _
"//api.authoring.ca/assets/read/1453746564131_56a669843a3c1dac741709333.png" & @CRLF & _
"//api.whatever.ca/assets/read/1453746564131_56a669843a3c1dac741709333.png" & @CRLF & _
"//api.whatever:8000/assets/read/1453746564131_56a669843a3c1dac741709333.png" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)