using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\/[a-z]+\.(?:[a-z]+\:?[0-9]+?|[a-z0-9]+\.[a-z]+)\/\bassets\b\/\bread\b\/((\w)+\.png)";
string substitution = @"$1";
string input = @"//api.localhost:8000/assets/read/1453746564131_56a669843a3c1dac74170930.png
//api.olguat2.ca/assets/read/1453746564131_56a669843a3c1dac74170938.png
//api.authoring.ca/assets/read/1453746564131_56a669843a3c1dac741709333.png
//api.whatever.ca/assets/read/1453746564131_56a669843a3c1dac741709333.png
//api.whatever:8000/assets/read/1453746564131_56a669843a3c1dac741709333.png
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}