# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/\/[a-z]+\.(?:[a-z]+\:?[0-9]+?|[a-z0-9]+\.[a-z]+)\/\bassets\b\/\bread\b\/((\w)+\.png)"
test_str = ("//api.localhost:8000/assets/read/1453746564131_56a669843a3c1dac74170930.png\n"
"//api.olguat2.ca/assets/read/1453746564131_56a669843a3c1dac74170938.png\n"
"//api.authoring.ca/assets/read/1453746564131_56a669843a3c1dac741709333.png\n"
"//api.whatever.ca/assets/read/1453746564131_56a669843a3c1dac741709333.png\n"
"//api.whatever:8000/assets/read/1453746564131_56a669843a3c1dac741709333.png\n\n")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.