import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Sys.Process\\(\\\"axium\\\"\\)(\\.Window\\((\\\"{0,1}(\\&*\\#*\\d*\\w*\\:*\\s*\\.*\\w*){1,10}\\\"{0,1}\\,{0,1}\\s{0,2}){1,3}\\)){1,10}\\.\\w*\\(*(\\\"*\\^*\\[*\\]*\\w*\\d*\\x81*\\d*\\\"*\\,*\\s*){1,10}\\)*";
final String string = "Sys.Process(\"axium\").Window(\"DX::MainFrame\", \"axiUm*\").Window(\"MDIClient\").Window(\"OWL_Window\", \"Inventory\").Window(\"#32770\", \"Inventory\").Window(\"Button\", \"&Transfer...\").ClickButton();";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}