import re
regex = re.compile(r"Sys.Process\(\"axium\"\)(\.Window\((\"{0,1}(\&*\#*\d*\w*\:*\s*\.*\w*){1,10}\"{0,1}\,{0,1}\s{0,2}){1,3}\)){1,10}\.\w*\(*(\"*\^*\[*\]*\w*\d*\x81*\d*\"*\,*\s*){1,10}\)*", flags=re.MULTILINE | re.IGNORECASE)
test_str = "Sys.Process(\"axium\").Window(\"DX::MainFrame\", \"axiUm*\").Window(\"MDIClient\").Window(\"OWL_Window\", \"Inventory\").Window(\"#32770\", \"Inventory\").Window(\"Button\", \"&Transfer...\").ClickButton();"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")