// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)Sys.Process\(\"axium\"\)(\.Window\((\"{0,1}(\&*\#*\d*\w*\:*\s*\.*\w*){1,10}\"{0,1}\,{0,1}\s{0,2}){1,3}\)){1,10}\.\w*\(*(\"*\^*\[*\]*\w*\d*\x81*\d*\"*\,*\s*){1,10}\)*"#).unwrap();
let string = "Sys.Process(\"axium\").Window(\"DX::MainFrame\", \"axiUm*\").Window(\"MDIClient\").Window(\"OWL_Window\", \"Inventory\").Window(\"#32770\", \"Inventory\").Window(\"Button\", \"&Transfer...\").ClickButton();";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}