#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\s*(\w+)\s*=\s*(?:'((?:[^'\\]|\\')*)'|"((?:[^"\\]|\\")*)"?|(\w+)))"
Local $sString = "{keyword name1=val1 name2='val2' name3="val3" name4="Isn't this OK?" name5=okay name6='Isn\'t' name7="A \"quote\""}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")