using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\s*(\w+)\s*=\s*(?:'((?:[^'\\]|\\')*)'|""((?:[^""\\]|\\"")*)""?|(\w+)))";
string input = @"{keyword name1=val1 name2='val2' name3=""val3"" name4=""Isn't this OK?"" name5=okay name6='Isn\'t' name7=""A \""quote\""}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}