import re
regex = re.compile(r"(?:\s*(\w+)\s*=\s*(?:'((?:[^'\\]|\\')*)'|\"((?:[^\"\\]|\\\")*)\"?|(\w+)))")
test_str = "{keyword name1=val1 name2='val2' name3=\"val3\" name4=\"Isn't this OK?\" name5=okay name6='Isn\\'t' name7=\"A \\\"quote\\\"\"}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")