import Foundation
let pattern = #"(?:\s*(\w+)\s*=\s*(?:'((?:[^'\\]|\\')*)'|"((?:[^"\\]|\\")*)"?|(\w+)))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"{keyword name1=val1 name2='val2' name3="val3" name4="Isn't this OK?" name5=okay name6='Isn\'t' name7="A \"quote\""}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)