// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:\s*(\w+)\s*=\s*(?:'((?:[^'\\]|\\')*)'|"((?:[^"\\]|\\")*)"?|(\w+)))"#).unwrap();
let string = "{keyword name1=val1 name2='val2' name3=\"val3\" name4=\"Isn't this OK?\" name5=okay name6='Isn\\'t' name7=\"A \\\"quote\\\"\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}