const regex = /(?:\s*(\w+)\s*=\s*(?:'((?:[^'\\]|\\')*)'|"((?:[^"\\]|\\")*)"?|(\w+)))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s*(\\w+)\\s*=\\s*(?:\'((?:[^\'\\\\]|\\\\\')*)\'|"((?:[^"\\\\]|\\\\")*)"?|(\\w+)))', 'g')
const str = `{keyword name1=val1 name2='val2' name3="val3" name4="Isn't this OK?" name5=okay name6='Isn\\'t' name7="A \\"quote\\""}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}