# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\"([a-zA-Z]\w+)\"(?=:)/$1/gm;t' <<< "props: {
\"label\": \"1rem\",
\"text3\": \"1rem\",
\"text2Button\": \"1rem\",
\"1\": \"1rem\",
\"5spacing\": 2
}"