const regex = /\"([a-zA-Z]\w+)\"(?=:)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\"([a-zA-Z]\\w+)\\"(?=:)', 'gm')
const str = `props: {
"label": "1rem",
"text3": "1rem",
"text2Button": "1rem",
"1": "1rem",
"5spacing": 2
}`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);