import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"([a-zA-Z]\\w+)\\\"(?=:)";
final String string = "props: {\n"
+ " \"label\": \"1rem\",\n"
+ " \"text3\": \"1rem\",\n"
+ " \"text2Button\": \"1rem\",\n"
+ " \"1\": \"1rem\",\n"
+ " \"5spacing\": 2\n"
+ "}";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}