re = /\"([a-zA-Z]\w+)\"(?=:)/m
str = 'props: {
"label": "1rem",
"text3": "1rem",
"text2Button": "1rem",
"1": "1rem",
"5spacing": 2
}'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result