#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)<base[ ]*?href=".+""
Local $sString = "<html><head><base href="/" /></head><body></body></html>" & @CRLF & _
"" & @CRLF & _
"<html>" & @CRLF & _
" <head>" & @CRLF & _
" <base href="/"/>" & @CRLF & _
" </head>" & @CRLF & _
" <body>" & @CRLF & _
" </body>" & @CRLF & _
"</html>" & @CRLF & _
"" & @CRLF & _
"<html>" & @CRLF & _
" <head>" & @CRLF & _
" <base href="/">" & @CRLF & _
" </head>" & @CRLF & _
" <body>" & @CRLF & _
" </body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")