import re
regex = re.compile(r"<base[ ]*?href=\".+\"", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("<html><head><base href=\"/\" /></head><body></body></html>\n\n"
"<html>\n"
" <head>\n"
" <base href=\"/\"/>\n"
" </head>\n"
" <body>\n"
" </body>\n"
"</html>\n\n"
"<html>\n"
" <head>\n"
" <base href=\"/\">\n"
" </head>\n"
" <body>\n"
" </body>\n"
"</html>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")