using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<base[ ]*?href="".+""";
string input = @"<html><head><base href=""/"" /></head><body></body></html>
<html>
<head>
<base href=""/""/>
</head>
<body>
</body>
</html>
<html>
<head>
<base href=""/"">
</head>
<body>
</body>
</html>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}