$re = '/<base[ ]*?href=".+"/mi';
$str = '<html><head><base href="/" /></head><body></body></html>
<html>
<head>
<base href="/"/>
</head>
<body>
</body>
</html>
<html>
<head>
<base href="/">
</head>
<body>
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);