use strict;
my $str = 'f46279ee-aa28-497c-982c-403ac0ea84a6';
my $regex = qr/\b([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{12})\b/mp;
my $subst = 'X\'\\4\\3\\2\\1\\6\\5\\8\\7\\9\\10\\11\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";