// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{12})\b").unwrap();
let string = "f46279ee-aa28-497c-982c-403ac0ea84a6";
let substitution = "X'\\4\\3\\2\\1\\6\\5\\8\\7\\9\\10\\11'";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}