re = /\b([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{12})\b/m
str = 'f46279ee-aa28-497c-982c-403ac0ea84a6'
subst = 'X\'\\4\\3\\2\\1\\6\\5\\8\\7\\9\\10\\11\''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result