# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\{.+\"from\":\"(\d+)\".+\"checkId\":\")(\d+)(\".+\"keyword\":\"([a-zA-Z]+)\".+\})/$1new Id$4\"checkId\":\"(new ID)\"/;t' <<< "{\"transfId\":\"S0722182156164591494745777M\",\"messageId\":\"123\",\"from\":\"5777\",\"to\":\"59395436474\",\"status\":-1,\"checkId\":\"1975\",\"price\":0,\"keyword\":\"OK\",\"errorCode\":601,\"errorMessage\":\"SUCCESS\",\"date\":\"20150730 09:00:00\",\"model\":\"wer_tr\"}"