import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\{.+\\\"from\\\":\\\"(\\d+)\\\".+\\\"checkId\\\":\\\")(\\d+)(\\\".+\\\"keyword\\\":\\\"([a-zA-Z]+)\\\".+\\})";
final String string = "{\"transfId\":\"S0722182156164591494745777M\",\"messageId\":\"123\",\"from\":\"5777\",\"to\":\"59395436474\",\"status\":-1,\"checkId\":\"1975\",\"price\":0,\"keyword\":\"OK\",\"errorCode\":601,\"errorMessage\":\"SUCCESS\",\"date\":\"20150730 09:00:00\",\"model\":\"wer_tr\"}";
final String subst = "$1new Id$4\\\"checkId\\\":\\\"(new ID)\\\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}