const regex = /(\{.+\"from\":\"(\d+)\".+\"checkId\":\")(\d+)(\".+\"keyword\":\"([a-zA-Z]+)\".+\})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\{.+\\"from\\":\\"(\\d+)\\".+\\"checkId\\":\\")(\\d+)(\\".+\\"keyword\\":\\"([a-zA-Z]+)\\".+\\})', '')
const str = `{"transfId":"S0722182156164591494745777M","messageId":"123","from":"5777","to":"59395436474","status":-1,"checkId":"1975","price":0,"keyword":"OK","errorCode":601,"errorMessage":"SUCCESS","date":"20150730 09:00:00","model":"wer_tr"}`;
const subst = `$1new Id$4\"checkId\":\"(new ID)\"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);