use strict;
my $str = '{"transfId":"S0722182156164591494745777M","messageId":"123","from":"5777","to":"59395436474","status":-1,"checkId":"1975","price":0,"keyword":"OK","errorCode":601,"errorMessage":"SUCCESS","date":"20150730 09:00:00","model":"wer_tr"}';
my $regex = qr/(\{.+\"from\":\"(\d+)\".+\"checkId\":\")(\d+)(\".+\"keyword\":\"([a-zA-Z]+)\".+\})/p;
my $subst = '$1new Id$4\\"checkId\\":\\"(new ID)\\"';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";