# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\{.+\"from\":\"(\d+)\".+\"checkId\":\")(\d+)(\".+\"keyword\":\"([a-zA-Z]+)\".+\})"
test_str = "{\"transfId\":\"S0722182156164591494745777M\",\"messageId\":\"123\",\"from\":\"5777\",\"to\":\"59395436474\",\"status\":-1,\"checkId\":\"1975\",\"price\":0,\"keyword\":\"OK\",\"errorCode\":601,\"errorMessage\":\"SUCCESS\",\"date\":\"20150730 09:00:00\",\"model\":\"wer_tr\"}"
subst = "$1new Id$4\\\"checkId\\\":\\\"(new ID)\\\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.