# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?=.*[A-Z])(?=.*[0-9]).*$//gm;t' <<< "nameA123
name
name1
name A 3
fooA1@##"