const regex = /^(?=.*[A-Z])(?=.*[0-9]).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*[A-Z])(?=.*[0-9]).*$', 'gm')
const str = `nameA123
name
name1
name A 3
fooA1@##`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);