$re = '/^(?=.*[A-Z])(?=.*[0-9]).*$/m';
$str = 'nameA123
name
name1
name A 3
fooA1@##';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;