use strict;
my $str = 'nameA123
name
name1
name A 3
fooA1@##';
my $regex = qr/^(?=.*[A-Z])(?=.*[0-9]).*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";