#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?=.*[A-Z])(?=.*[0-9]).*$"
Local $sString = "nameA123" & @CRLF & _
"name" & @CRLF & _
"name1" & @CRLF & _
"name A 3" & @CRLF & _
"fooA1@##"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)