import Foundation
let pattern = #"^(?=.*[A-Z])(?=.*[0-9]).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ###"""
nameA123
name
name1
name A 3
fooA1@##
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)