# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[([^]]+)\]\(([^)]+)\)/<A HREF="$2">$1<\/A>/;t' <<< "[Site Description](http://www.stackoverflow.com)"