// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[([^]]+)\]\(([^)]+)\)").unwrap();
let string = "[Site Description](http://www.stackoverflow.com)";
let substitution = "<A HREF=\"$2\">$1</A>";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}