const regex = /\[([^]]+)\]\(([^)]+)\)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[([^]]+)\\]\\(([^)]+)\\)', '')
const str = `[Site Description](http://www.stackoverflow.com)`;
const subst = `<A HREF="$2">$1</A>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);