re = /\[([^]]+)\]\(([^)]+)\)/
str = '[Site Description](http://www.stackoverflow.com)'
subst = '<A HREF="$2">$1</A>'
result = str.sub(re, subst)
# Print the result of the substitution
puts result