$re = '/\[([^]]+)\]\(([^)]+)\)/';
$str = '[Site Description](http://www.stackoverflow.com)';
$subst = "<A HREF=\"$2\">$1</A>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;