using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[([^]]+)\]\(([^)]+)\)";
string substitution = @"<A HREF=""$2"">$1</A>";
string input = @"[Site Description](http://www.stackoverflow.com)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}