using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*\([^()]*\)$";
string substitution = @"";
string input = @"*AWL* (GREATER) MINDS LIMITED (CLOSED)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}