use strict;
my $str = '*AWL* (GREATER) MINDS LIMITED (CLOSED)';
my $regex = qr/\s*\([^()]*\)$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";