import Foundation
let pattern = #"\s*\([^()]*\)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"*AWL* (GREATER) MINDS LIMITED (CLOSED)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)