re = /\s*\([^()]*\)$/
str = '*AWL* (GREATER) MINDS LIMITED (CLOSED)'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result