package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*\([^()]*\)$`)
var str = `*AWL* (GREATER) MINDS LIMITED (CLOSED)`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}