#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:729)?\d+(?:[a-zA-Z])*\.(?:jpg|png))"
Local $sString = "12345#jpg" & @CRLF & _
"7290000232.png" & @CRLF & _
"0000232.jpg" & @CRLF & _
"232.png" & @CRLF & _
"000005234abcdef.jpg" & @CRLF & _
"abcede23123.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")