using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:729)?\d+(?:[a-zA-Z])*\.(?:jpg|png))";
string input = @"12345#jpg
7290000232.png
0000232.jpg
232.png
000005234abcdef.jpg
abcede23123.jpg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}