package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:729)?\d+(?:[a-zA-Z])*\.(?:jpg|png))`)
var str = `12345#jpg
7290000232.png
0000232.jpg
232.png
000005234abcdef.jpg
abcede23123.jpg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}