import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:729)?\\d+(?:[a-zA-Z])*\\.(?:jpg|png))";
final String string = "12345#jpg\n"
+ "7290000232.png\n"
+ "0000232.jpg\n"
+ "232.png\n"
+ "000005234abcdef.jpg\n"
+ "abcede23123.jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}