$re = '/^((?:729)?\d+(?:[a-zA-Z])*\.(?:jpg|png))/m';
$str = '12345#jpg
7290000232.png
0000232.jpg
232.png
000005234abcdef.jpg
abcede23123.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);